User Tag List

Gracias Gracias:  0
Me agrada Me agrada:  0
Me desagrada Me desagrada:  0
Resultados 1 al 4 de 4

Tema: IPv6 en Mikrotik. Configurar WAN con IP estatica + LAN

  1. #1

    Fecha de ingreso
    19 Apr, 21
    Mensajes
    51
    Reconocimientos
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IPv6 en Mikrotik. Configurar WAN con IP estatica + LAN

    Se pretende llegar al siguiente diagrama:

    Nombre:  IPv6-Basico-4.jpg
Visitas: 3046
Tamaño: 120.9 KB

    Descripción

    Nuestro carrier Total Play nos hace entrega de un prefijo IPv6 /48.
    Con ese prefijo nosotros tenemos que configurar el Mikrotik para tener salida a Internet.
    Lo primero es configurar nuestra conexión IPv6 con el carrier, para ello tenemos que solicitarle los parámetros de configuración. El carrier nos indicará que IPv6 usaremos nosotros y que IPv6 usaran ellos.
    Lo segundo es agregar nuestro prefijo /48 a un pool de Mikrotik.

    Después vamos a configurar nuestra interface LAN (ether-5) en el Mikrotik. Para ello vamos a utilizar una IPv6 con prefijo /64.
    Finalmente conectaremos una laptop a nuestro Mikrotik y automáticamente nos debe de dar una IPv6 y con eso podremos navegar en Internet.


    Paso 1.1

    Configurar WAN
    Nos vamos a asignar la IPv6 que nuestro proveedor nos indique en la interface WAN. Para este ejemplo esa interface es la Ether-1.

    Código:
    /ipv6 addressadd address=2806:3f7:1002::ffff:f0ca:bebe/112 advertise=no comment=Enlace-con-CARRIER interface=ether1


    Nombre:  1.1.png
Visitas: 3061
Tamaño: 59.7 KB

    Paso 1.2
    Agregar ruta estática hacia el carrier

    Código:
    /ipv6 route add comment="Ruta estatica hacia el Carrier" distance=1 gateway=2806:3f7:1002::ffff:f0ca:f0ca
    Nombre:  2.1.png
Visitas: 3051
Tamaño: 64.1 KB


    Paso 2 Subnetear nuestro prefijo /48

    Antes de continuar al siguiente paso vamos a explicar brevemente como vamos a distribuir el prefijo /48 que nuestro carrier nos esta entregando. Para ellos podemos ir al sitio web https://www.site24x7.com/es/tools/ip...lculadora.html

    Nombre:  subneteo.jpg
Visitas: 3045
Tamaño: 151.9 KB
    Como podemos ver al tener un /48 podemos usar hasta 65,536 prefijos /64. Es una cantidad enorme, probablemente nunca usemos todos esos prefijos.
    Una manera de verlo es en una relación de padres e hijos.

    Prefijo padre ---> 2806:3F7:A200::/48
    Prefijo hijo ------> 2806:3F7:A200:CCCC:/64

    Nosotros podemos elegir cualquiera de esos 65,536 prefijos hijos para nuestras redes LAN. Todos van a funcionar.
    Para este caso hemos elegido el prefijo 2806:3F7:A200:CCC::/64.
    Ahora bien, en cada prefijo /64 tenemos disponibles más de 18 millones de IPv6 aproximadamente, estas IPv6 pueden ser asignadas a un equipo ya sea una computadora, un celular o una televisión.

    Paso 3.1
    Agregar nuestro prefijo a un Pool

    Nota


    Un pool no es más que un objeto donde se almacenan prefijos, estos pool son usados por otras herramientas. Normalmente se usan para que Mikrotik tome algunas IPs de ese pool y las reparta a otros dispositivos.

    Código:
    /ipv6 pool add name=my-pool prefix=2806:3f7:a200::/48 prefix-length=64


    Nombre:  3.1.png
Visitas: 3055
Tamaño: 59.8 KB
    Paso 4.1
    Configurar nuestra interface LAN

    Opción 1: Dejar que el Mikrotik se autoconfigure

    Simplemente dejamos que el Mikrotik escoja su propia IPv6. Es importante dejar la opción de "Advertise". Esto hará que el Mikrotik reparta una IPv6 a cada equipo de la red LAN.

    Código:
    /ipv6 address add comment=LAN from-pool=my-pool interface=ether5


    Nombre:  4.1.png
Visitas: 3060
Tamaño: 98.9 KB
    Opción 2:
    La mejor opción siempre va a ser escoger nosotros mismos la IPv6 que llevará el Mikrotik. Para ello usaremos la IPv6 que se muestra en el primer diagrama
    2806:3f7:a200:CCCC::AAAAA/64.

    Nota

    Esta es la forma recomendada ya que la IPv6 escogida tendrá algún sentido y será fácil de recordar.


    Código:
    /ipv6 addressadd address=2806:3f7:a200:CCCC::AAAAA comment=LAN interface=ether5

    Nombre:  3.1 asignar ip static.jpg
Visitas: 3040
Tamaño: 133.5 KB

    Realmente podemos usar cualquiera de las 18 millones de IPv6 como explicamos en el paso 2. Por simplicidad debemos elegir uno que será fácil de recordar.
    Unos ejemplo serían:
    2806:3F7:a200:cccc::BABA/64
    2806:3F7:a200:cccc::F0C0/64 (parecido a Foco)
    2806:3F7:a200:cccc:ded0/64 (parecido a Dedo)

    Paso 4.2
    Habilitar "other configuration". Esto es necesario para que las PC con Windows reciban una IPv6.

    Código:
     /ipv6 nd set [ find default=yes ] other-configuration=yes
    Nombre:  habilitar-nd.png
Visitas: 3058
Tamaño: 89.5 KB

    Paso 5.1

    Conectar una Laptop al puerto LAN del Mikrotik

    Al conectar nuestra laptop automáticamente nos dará una IPv6.

    Nombre:  5.13-bueno.jpg
Visitas: 3025
Tamaño: 122.1 KB

    Paso 5.2

    Probamos conectividad a los DNS de Google
    Para lograr esto podemos valernos de unos simples pings hacia google o la IPv6 mostrada en el diagrama
    2001:4860:4860::8888.

    De igual forma podemos abrir un navegador web e ir hacia la siguiente URL https://test-ipv6.com/. En este sitio nos hacen un test que validará que nuestra salida a Internet con IPv6 sea correcta.

    Nombre:  5.2.jpg
Visitas: 3045
Tamaño: 170.5 KB


    Imágenes adjuntadas Imágenes adjuntadas      
    Última edición por HECTORCHIMAL; 30/05/2023 a las 12:01

  2. #2

    Fecha de ingreso
    06 Dec, 22
    Mensajes
    25
    Reconocimientos
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    En la versión 7 del mikrotik verifica que este anunciado el prefijo /36

  3. #3
    Avatar de oscar
    Fecha de ingreso
    06 Mar, 19
    Mensajes
    57
    Reconocimientos
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

  4. #4
    Avatar de josemiguel
    Fecha de ingreso
    08 Sep, 22
    Mensajes
    15
    Reconocimientos
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Actualización

    Se pretende llegar al siguiente diagrama:
    Nombre:  ipv6 diagrama final v2.jpg
Visitas: 1695
Tamaño: 117.4 KB

    ​CONFIGURACIÓN ROUTER ADMIN 1

    Paso 1.1

    Configurar WAN
    Nos vamos a asignar la IPv6 que nuestro proveedor nos indique en la interface WAN. Para este ejemplo
    esa interface es la Ether-1
    Código:

    /ipv6 address add address=2806:040c:6001:eeee:eeee:eeee:000a:cccc/112 advertise=no comment=Enlace con BGP - 2
    interface=ether1


    Nombre:  configuracion-wan-ipv6.png
Visitas: 2456
Tamaño: 69.4 KB

    Paso 1.2
    Agregar ruta estática hacia el BGP

    Código:
    /ipv6 route comment="Ruta estatica hacia el BGP" distance=1 gateway=2806:040c:6001:eeee:eeee:eeee:000a:ffff


    Nombre:  ruta-ipv6.png
Visitas: 2471
Tamaño: 84.1 KB

    Paso 2 Subnetear nuestro prefijo /48

    Equipo Interface Direccionamiento Descripción
    Router BGP - 1 SFP 2001:db8:3333:4444:5555:6666:7777:8888/32 IPv6 del carrried
    Router BGP - 1 Ether 1 2806:03f7:1004:bbbb:bbbb:bbbb:f0ca:f0ca/112 Este es el gateway para el BGP 2
    Router BGP - 2 Ether 1 2806:03f7:1004:bbbb:bbbb:bbbb:f0ca:bebe/112 Enlace con carrier para sesion BGP
    Router BGP - 2 Ether 2 2806:040c:6001:eeee:eeee:eeee:000a:ffff/112 Este será nuestro gateway para Router Admin 1
    Router Admin 1 Ether 1 2806:040c:6001:eeee:eeee:eeee:000a:cccc/112 Enlace con nuestro proveedor
    Router Admin 1 Ether 5 2806:040c:6001:cccc:1111:1111:1111:0254/64 Interfaz para clientes
    Laptop Ethernet 2806:040c:6002:cccc:7fff:ffff:ffff:ffff/64 Laptop

    Descripción Direccionamiento Nota
    Prefijo asignado 2806:40c:6000::/36 Subnetear a /48, uno para enlace y otro para clientes
    Prefijo usado para enlace 2806:40c:6001::/48 Subnetear a /112 para hacer enlace con router BGP
    Prefijo del carrier para usarlo en la red de clientes 2806:40c:6002::/48 Subnetear a /64 para cada cliente

    Antes de continuar al siguiente paso vamos a explicar brevemente como vamos a distribuir el prefijo /48 que nuestro carrier nos esta entregando. Para ellos podemos ir al sitio web https://www.site24x7.com/es/tools/ip...lculadora.html
    Nombre:  subneteo-ipv6.jpg
Visitas: 2442
Tamaño: 128.6 KB
    Como podemos ver al tener un /48 podemos usar hasta 65,536 prefijos /64. Es una cantidad enorme, probablemente nunca usemos todos esos prefijos.
    Una manera de verlo es en una relación de padres e hijos.

    Prefijo padre ---> 2806:40c:6001::/48
    Prefijo hijo ------> 2806:40c:6001:cccc:/64

    Nosotros podemos elegir cualquiera de esos 65,536 prefijos hijos para nuestras redes LAN. Todos van a
    funcionar.
    Para este caso hemos elegido el prefijo 2806:40c:6001:cccc:/64.
    Ahora bien, en cada prefijo /64 tenemos disponibles más de 18 millones de IPv6 aproximadamente,
    estas IPv6 pueden ser asignadas a un equipo ya sea una computadora, un celular o una televisión.


    Paso 3.1
    Agregar nuestro prefijo a un Pool

    Nota


    Un pool no es más que un objeto donde se almacenan prefijos, estos pool son usados por otras herramientas. Normalmente se usan para que Mikrotik tome algunas IPs de ese pool y las reparta a otros dispositivos.


    /ipv6 pool add name=my-pool prefix=2806:40c:6001::/48 prefix-length=64


    Nombre:  pool-ipv6.png
Visitas: 2489
Tamaño: 66.4 KB

    Paso 4.1
    Configurar nuestra interface LAN

    Opción 1: Dejar que el Mikrotik se autoconfigure

    Simplemente dejamos que el Mikrotik escoja su propia IPv6. Es importante dejar la opción de "Advertise". Esto hará que el Mikrotik reparta una IPv6 a cada equipo de la red LAN.

    Nota

    Al dar clic en Apply automaticamente se nos genera el campo de Address, asi que no es necesario ponerlo manualmente,


    /ipv6 address add comment=LAN from-pool=my-pool interface=ether5


    Nombre:  lan-pool-ipv6.png
Visitas: 2446
Tamaño: 74.3 KB

    Opción 2:
    La mejor opción siempre va a ser escoger nosotros mismos la IPv6 que llevará el Mikrotik. Para ello usaremos la IPv6 que se muestra en el primer diagrama 2806:40c:6002:cccc:1111:1111:1111:0254/64.

    Nota

    Esta es la forma recomendada ya que la IPv6 escogida tendrá algún sentido y será fácil de recordar.


    /ipv6 address add address=2806:40c:6002:cccc:1111:1111:1111:0254/64 comment=LAN
    interface=ether5


    Nombre:  lan-manual-ipv6.png
Visitas: 2484
Tamaño: 81.7 KB

    Paso 4.2
    Habilitar "other configuration". Esto es necesario para que las PC con Windows reciban una IPv6.

    /ipv6 nd set [ find default=yes ] other-configuration=yes


    Nombre:  other-config-ipv6.png
Visitas: 2453
Tamaño: 78.0 KB

    Paso 5.1
    Conectar una Laptop al puerto LAN del Mikrotik

    Al conectar nuestra laptop automáticamente nos dará una IPv6.
    Nombre:  connect-laptop-ipv6png.png
Visitas: 2462
Tamaño: 414.6 KB

    Paso 5.2
    Probamos conectividad a los DNS de Google
    Para lograr esto podemos valernos de unos simples pings hacia google o la IPv6 mostrada en el diagrama
    2001:4860:4860::8888.

    ping 2001:4860:4860::8888


    Nombre:  ping-dns-ipv6.png
Visitas: 2469
Tamaño: 527.6 KB

    De igual forma podemos abrir un navegador web e ir hacia la siguiente URL https://test-ipv6.com/. En este sitio nos hacen un test que validará que nuestra salida a Internet con IPv6 sea correcta.

    Nombre:  test-connect-ipv6.png
Visitas: 2476
Tamaño: 552.5 KB


    Paso 5.3
    Activar los DNS

    Para que puedan abrir las paginas debemos activar los DNS

    /ip dns set servers=8.8.8.8,8.8.4.4,2001:4860:4860::8888,2001:  4860:4860::8844


    Nombre:  activar-dns-ipv6.png
Visitas: 2434
Tamaño: 75.9 KB


    CONFIGURACIÓN BGP - 2

    Si el resultado no es el esperado, verificar en el BGP la configuracion del puerto ETH y la ruta que
    debe tener sobre la WAN de la configuracion que acabamos de hacer

    Eth8 (Ejemplo)
    2806:40c:6001::a:ffff/112

    Nombre:  eth-bgp-ipv6.png
Visitas: 2436
Tamaño: 30.9 KB


    Ruta:
    2806:40c:6001::a:cccc con destino a 2806:40c:6000::/36

    Nombre:  ruta-bgp-ipv6.png
Visitas: 2453
Tamaño: 59.1 KB

    Es necesaria esta configuracion para que los dispositivos tengan servicio, ya que sin esta configuración
    en el BGP solo tendremos servicio en el mikrotik pero no los dispositivos no.

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •